Date |
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Authors | |
Status | In Progress |
Summary |
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Impact | User could not manage connections |
Table of Contents |
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Non-technical summary
Reval was showing information that had not been updated from GMC, on further investigation it turned out that the jobs that run overnight to get the data from GMC and then add it into TIS had not run successfully. Once they had been fixed and rerun, Reval showed the correct information.
Timeline
09:23 am | |||
09:45 | we re-ran gmc sync - returning 0 doctors per designated body | ||
10:00 Ish | investigations found that
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10:15 AM | Emailed GMC | ||
12:06 | More correspondance with the GMC as they asked for calrifcation on envrionments | ||
Root Causes
Trigger
A user reported in Teams Support Channel that their connections had not been working correctly
Resolution
R
Detection
A user reported in Teams Support Channel
Actions
For new reval - we need add monitoring so we know if the sync job to get the data from GMC and if we build any ETL/Transformation service are run successfully or fail - we could use this ticket https://hee-tis.atlassian.net/browse/TISNEW-3264
Decision taken not to address the monitoring in the current reval application as the new one is pretty close to being live (December 2020)
Lessons Learned (Good and Bad)
Still limited knowledge within the existing teams about how the existing module works (which is why the rebuild is taking place)
Current monitoring requires more investment to get it to work more reliably - problems with set to fail on the first occurrence and alerting would need to be written into the individual apps rather than checking of logs
Jobs need to be started via Jenkins
check the jenkins jobs for 1. what they do, and 2. what the logs for that run said.