Date |
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Authors | |
Status | ResolvedIn Progress |
Summary |
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Impact |
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08:08 | |
08:30 | Created ticket and incident page |
09:15 | Rerun failed with the same error… Forbidden (HTTP 403) |
09:33 | Pinged users to let them know we have contacted GMC to check the issue |
09:34 AM | Emailed GMC |
10:43 | Replied to GMC to confirm its the production/LIVE Envrionment and not our new Reval module |
11:47 | GMC have made some changes over the weekend, they are looking into it |
16:10 | Email to chase GMC |
16:31 | |
- 16:53 | Confirming with the GMC what IPs we are hitting |
17:50 PM | Email back from GMC |
10:55 | We found that with the new reval module, no issues, we are able to get data However, the issue is with legacy/existing. Need to check if the IPs/Servers that legacy reval runs on are still whitelisted |
11:01 AM | |
11:46 | Cheking if authentication error |
16:10 | We confused the GMC |
- 11:17 | Call to investigate further - more fault analysis done,
Some Findings
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- 14:00 |
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-14:11 |
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-14:41 |
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- 15:17 |
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- 15:30 |
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- 16:33 | Email to GMC |
- 16:38 | So just to sum up our thought process:
Conclusion: most likely cause is a permissions error (Authorization issue) internally on GMC side |
- 16:42 | |
- 16:50 | Updated users on teams with our conclusion |
- 17:06 | Clarification of IPs |
-05:47 | |
- 22:02 | Email from the GMC - they have been able to re-create the 403 error |
- 22:48 to 23:19 |
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- 00:05 |
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- 08:02 |
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- 08:08 |
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- 09:59 | Trying to get some clarification from the GMC relating to the user agent |
- 11:26 | GMC disable the security feature relating to the user agent so thats why it worked We need to update the user agent |
Root Causes
Job failed
Request to “Get to GMC Doctors From GMC API” 403
The GMC moved the API behind some additional security over the weekend - cloud flare CND, DDoS Platform
Requests were being sent with a user agent blocked by Cloudflare
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