2021-03-01 Legacy Reval: unable to submit revalidation - User Agent/Cloudflare GMC Issue
Date | Mar 1, 2021 |
Authors | @Philip Wilsdon (Unlicensed) |
Status | Completed |
Summary |
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Impact |
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Non-technical summary
GMC added a new security platform
The platform allows them to block incoming requests
They blocked ours but then disabled it
They will not block requests anymore until the new reval is live
Will not be an issue with new reval - it is written in a more up to date language version and is not blocked by the GMC filtering criteria
Timeline
Mar 1, 2021 08:08 | |
Mar 1, 2021 08:30 | Created ticket and incident page 2021-03-01 Legacy Reval: unable to submit revalidation - User Agent/Cloudflare GMC Issue |
Mar 1, 2021 09:15 | Rerun failed with the same error… Forbidden (HTTP 403) |
Mar 1, 2021 09:33 | Pinged users to let them know we have contacted GMC to check the issue |
Mar 1, 2021 09:34 | Emailed GMC |
Mar 1, 2021 10:43 | Replied to GMC to confirm its the Production/Live environment and not our new Reval module |
Mar 1, 2021 11:47
| GMC have made some changes over the weekend, they are looking into it |
Mar 1, 2021 16:10 | Email to chase GMC |
Mar 1, 2021 16:31 | |
Mar 1, 2021 16:53 | Confirming with the GMC what IPs we are hitting |
Mar 1, 2021 17:50 | Email back from GMC |
Mar 2, 2021 10:55 | We found that with the new reval module, no issues, we are able to get data However, the issue is with legacy/existing. Need to check if the IPs/Servers that legacy reval runs on are still whitelisted |
Mar 2, 2021 11:01 | |
Mar 2, 2021 11:46 | Checking if authentication error |
Mar 2, 2021 16:10 | We confused the GMC |
Mar 3, 2021 11:17 | Call to investigate further - more fault analysis done,
Some Findings
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Mar 3, 2021 14:00 |
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Mar 3, 2021 14:11 |
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Mar 3, 2021 14:41 |
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Mar 3, 2021 15:17 |
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Mar 3, 2021 15:30 |
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Mar 3, 2021 16:33 | Email to GMC
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Mar 3, 2021 16:38 | So just to sum up our thought process:
Conclusion: most likely cause is a permissions error (Authorization issue) internally on GMC side |
Mar 3, 2021 16:42 | |
Mar 3, 2021 16:50 | Updated users on teams with our conclusion |
Mar 3, 2021 17:06 | Clarification of IPs |
Mar 3, 2021 05:47 | |
Mar 3, 2021 22:02 | Email from the GMC - they have been able to re-create the 403 error |
Mar 3, 2021 22:48 to 23:19 |
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Mar 4, 2021 00:05 |
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Mar 4, 2021 08:02 |
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Mar 4, 2021 08:08 |
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Mar 4, 2021 09:59 | Trying to get some clarification from the GMC relating to the user agent |
Mar 4, 2021 11:26 | GMC disabled the security feature relating to the user agent so thats why it worked We need to update the user agent |
Mar 4, 2021 13:05 | |
Mar 8, 2021 10:06 | Chasing GMC - No reply regarding User agent / is there filtering back on? |
Mar 8, 2021 14:18 | Reply from GMC and some thoughts
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Mar 8, 2021 15:37 |
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Mar 8, 2021 16:33 |
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Root Causes
Job failed
Request to “Get to GMC Doctors From GMC API” 403
Contacted the GMC (peter.mcnair@gmc-uk.org) - they moved the API behind some additional security on the Mar 8, 2021 - a Cloudflare CND, DDoS Platform
Requests were being sent were being blocked based on filtering rules they had set up - blocking the user agent
Trigger
GMC introducing Cloudflare which blocked our calls to their API
Resolution
GMC has turned off the filtering and will leave it disabled until the new reval module is deployed
Detection
Slack monitoring and user report in Teams Support Channel
Actions
Inform GMC when only new reval module is live so
Lessons Learned (Good and Bad)
Cloudflare adds additional security e.g. block requests based on certain rules such as user agents
GMC do server upgrades/maintenance etc on Sundays/over the weekend
Slack: https://hee-nhs-tis.slack.com/
Jira issues: https://hee-tis.atlassian.net/issues/?filter=14213