2017-08-02 DR password expired
Date | 2017-08-02 |
Authors | |
Status | Resolved |
Summary | Unable to connect to DR DB using Transform user, and unable to change Transform password when prompt |
Impact | Causing nightly ETL to fail |
Root Cause
From: Russell Steel
Sent: 02 August 2017 08:58:39
To: Martin.Stanford@hicom.co.uk; Yvonne.Cunningham@hicom.co.uk
Cc: Graham ORegan (TIS External Contractor)
Subject: Unable to login into DR DB @212.250.207.206,4589 using Transform user
I'm getting the following error when trying to connect to the DR this morning;
I also had this error yesterday, but was able to resolve it by specifying the Connect to database to Master;
using <default>, master, masterdb or Intrepid.DataRepository all resort in error 4064
Please can you advise on how to resolve this error ?
From: Russell Steel [mailto:russell.steel@transformuk.com]
Sent: 02 August 2017 14:09
To: Yvonne Cunningham <Yvonne.Cunningham@hicom.co.uk>; Graham O'Regan <graham.oregan@transformuk.com>; Reuben Noot <reuben.noot@hee.nhs.uk>
Subject: Re: Unable to login into DR DB @212.250.207.206,4589 using Transform user
Thank Yvonne, all connected again without issue.
Going forward we'd like to be able to update the password before it expires, but looks like we don't have the permission to do this;
From: Yvonne Cunningham <Yvonne.Cunningham@hicom.co.uk>
Sent: 02 August 2017 15:03:47
To: Russell Steel; Graham O'Regan; Reuben Noot
Subject: RE: Unable to login into DR DB @212.250.207.206,4589 using Transform user
Hi All
Are you connecting via SSMS or some other method?
I have been told that if you log on via SSMS you should be prompted to reset your password once it has expired.
From: Russell Steel [mailto:russell.steel@transformuk.com]
Sent: 02 August 2017 15:07
To: Yvonne Cunningham <Yvonne.Cunningham@hicom.co.uk>; Graham O'Regan <graham.oregan@transformuk.com>; Reuben Noot <reuben.noot@hee.nhs.uk>
Subject: Re: Unable to login into DR DB @212.250.207.206,4589 using Transform user
I'm using SSMS, this morning I was being prompted for a password change, but got error 4064, now the password has been reset, and if I try to change it manually via SSMS, I get error code 15151.
From: Yvonne Cunningham <Yvonne.Cunningham@hicom.co.uk>
To: Russell Steel; Graham O'Regan; Reuben Noot
Subject: RE: Unable to login into DR DB @212.250.207.206,4589 using Transform user
Ok, we’ll take a look.
Trigger
Resolution
Hicomm reset the Transform password for us.
Detection
Action Items
Action Item | Type | Owner | Issue |
---|---|---|---|
mitigate/prevent | |||
Timeline
Supporting Information
e.g. monitoring dashboards
Slack: https://hee-nhs-tis.slack.com/
Jira issues: https://hee-tis.atlassian.net/issues/?filter=14213